Repairing ZX Spectrum +2A tape deck

On ZX Spectrum +2A I have a tape deck was not working. Well actually it was working, but games were not loading as it seemed like the signal was missing. I will not go into details of disassembling ZX Spectrum +2 as it is pretty obvious. You get access to PCB of tape dec right away, to turn it around You have to unscrew couple of screws and that is all.

Without any deeper investigation after disassembly I decided to do couple of things right away:

  • replace all electrolytic capacitors with new ones,
  • replace HA17324 operation amplifier with LM324

But unfortunately and to my surprise, after this hassle nothing changed, still the same issue.

Then I noticed that something wrong with the powering on the board and it seems like the ground was missing.

After some further investigation, I have found that ground on the board was delivered by two bold that was holding the board, as the board was removed, there was no ground in one part of the board. And maybe due to oxidation or something like that ground initially was an issue. I have inserted back HA17324, added a jumper between grounds just to be sure and it seems problems were solved.

So here You go, if You have ZX Spectrum +2 tape working but no signal, check ground first.

 

Repairing ZX Spectrum +2A, composite video mod

I have purchased ZX Spectrum +2A to my collection and as with +3 decided to add a composite video out.

First what I did I made this RGB mod to get s-video out, by:

1. Removing the 12V from pin 1 by removing resistor R44 (should be the same for +2A, +2B and +3, and very close to the RGB connector).
2. Adding this circuit

zx spectrum +3 composite video mod

Also detached audio from video by removing C24 and shorting from R46 to R56:

I got the video out and it seemed ok at first, but when doing self-tests the result was a washout picture:

ZX Spectrum +2A/+3 Schematic:

Z70830

ZX Spectrum 128K video fixes and video cables:

ZX Spectrum 128K video fixes and video cables

Some useful links:

ZX Spectrum 128k +2 repairs

Removing Blue/Yellow Ghosting from the 128/+2’s Video Output

 

https://sites.google.com/site/lost8bits/sk/sk-zx-spectrum/sk-datacoder-fix